Body
Issue/Question
How do I check the status of my tickets in Team Dynamix?
Environment
Cause
I need to check on a ticket I submitted and find out what is going on with it.
Resolution/Answer
- There are several ways to check the status of your ticket. The most direct route is on the home page of Team Dynamix/ the Service Desk Client Portal.
- Visit sd.westmoreland.com and sign in.
- Click on View my tickets on the left side of the screen.

- The next window provides a list of tickets you've submitted and their statuses.

- You can click on any ticket and use the Comment button near the bottom of the ticket details in order to get a current update from the technician working on your issue.
- You can also respond to the email you received from the IT Service Desk and that will also request an update for that ticket.
Show Me How:
Here's a link to a video that will show you how: Link