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Overview
Document created to show end users on Xfinity internet service to change their IP range on their home network Xfinity provided equipment.
Environment
Users using Xfinity/Comcast Internet service.
- Cell phone (Android or Apple)
- Xfinity Application installed on phone
Cause
The default IP range utilized by Xfinity of 10.0.0.x conflicts with Zscaler VPN and causes odd timeout issues and slow loading webpages. If your home network also includes a secondary WiFi router, it must be rebooted at the end of the process.
Resolution/Answer
1. Install (if it is not already) the Xfinity application on your phone using your phone’s Store.

2. Will need to sign in using your Xfinity account information. (This is possibly written on the bottom of your Xfinity modem.)
3. Once signed in – you will select the “Connect” at the bottom of the app.

4. Then Select “View WiFi equipment.”

5. Select “Advanced Settings” near the bottom of the screen.

6. Select “LAN & WAN” option.

7. Under the LAN & WAN section, Select “Edit.”

8. Under the “Local IP (IPv4)” change the 10.0.0.1 to 192.168.0.1 and click on “Apply Changes”


9. This will change your home IP address ranges – and will automatically reassign IP address to items connected to the router.
You may have to reboot devices on your home network for them to get the new settings. Start with any additional WiFi routers or mesh WiFi systems you may have. If any other devices are having trouble connecting to the internet, reboot them and they will get the new settings.